Personal data verification issues
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted 8 days ago. Aug 13, 2019 - 17:05 PDT
Investigating
We’re investigating issues with personal data verifications for some customers. We’ll update as we know more.
Posted 8 days ago. Aug 13, 2019 - 16:21 PDT
This incident affected: ID verification.