Issues with identity verification
Incident Report for Coinbase
Update
Some customers may experience a delay with ID verification. We'll update as we know more.
Posted Jan 13, 2021 - 22:10 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 10, 2021 - 13:27 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 10, 2021 - 13:24 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 08, 2021 - 17:04 PST
This incident affects: User Proofing (Proof of Address, ID verification).