Outgoing SEPA Payments Delayed
Incident Report for Coinbase
Resolved
We have resolved the issue that was causing delayed SEPA payments. No customer funds were delayed as a result of this incident.
Posted 3 months ago. Oct 02, 2017 - 14:17 PDT
Identified
Our team has identified an issue that is causing outgoing SEPA payments to be delayed. We are working to address the problem as quickly as possible.
Posted 3 months ago. Oct 02, 2017 - 10:40 PDT