Degraded Phone Support

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted Aug 08, 2024 - 13:43 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 08, 2024 - 12:48 PDT

Investigating

We are aware that customers may be unable to connect with Coinbase support via phone or requested phone call. We are aware of this issue and working to resolve this issue quickly. Chat support is not impacted.
Posted Aug 08, 2024 - 12:30 PDT