Ethereum buys and sells are temporarily disabled.
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Dec 12, 2017 - 11:45 PST
Investigating
Ethereum buys and sells are temporarily disabled.
Posted Dec 12, 2017 - 11:04 PST