Base App & Wallet Extension Performance - Bitcoin Transactions

Incident Report for Coinbase

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 03, 2026 - 12:05 PST

Investigating

We are aware that some users may be experiencing latency or degraded performance when attempting Bitcoin transactions from the Base app and wallet extension. Our team is investigating this issue and will provide an update shortly. Your funds are safe.
Posted Mar 03, 2026 - 12:04 PST
This incident affects: Coinbase Wallet - Extension and Base app (formerly Coinbase Wallet) - Mobile.