SEPA Delays
Incident Report for Coinbase
Resolved
Issues with incoming SEPA deposits has been resolved.
Posted 12 days ago. Sep 12, 2017 - 13:01 PDT
Identified
Incoming SEPA deposits may be delayed. All outgoing SEPA payments should function normally. Our team has identified the issue and is working toward a resolution.
Posted 12 days ago. Sep 12, 2017 - 10:56 PDT