Delayed Paypal Withdrawals
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Dec 20, 2020 - 11:10 PST
Update
We are continuing to investigate this issue.
Posted Dec 20, 2020 - 10:20 PST
Investigating
We are currently investigating an issue with Paypal withdrawals.
Posted Dec 20, 2020 - 10:20 PST
This incident affected: Payment Methods (PayPal).