Degraded Performance - Easy Bank Transfer

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 13:49 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2025 - 13:49 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 21, 2025 - 13:49 PDT

Investigating

We are aware that customers in the UK and EU may be unable to buy and deposit via Easy Bank Transfer on web and mobile due to an external vendor issue. Customers can attempt their transaction with the other payment methods available such as Card/Google Pay/Apple Pay. Our team is investigating this issue and will provide an update. Your funds are safe.
Posted Apr 21, 2025 - 12:39 PDT