Slow load times & degraded performance
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted May 23, 2017 - 14:55 PDT
Investigating
We're experiencing slower than normal load times and some customers may have issues loading our website. We're investigating the issue & will provide updates shortly.
Posted May 23, 2017 - 14:46 PDT