ID Verification Investigation
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 21:32 PDT
Investigating
We're investigating issues with ID verifications for some customers. We'll update as we know more.
Posted Mar 12, 2020 - 20:28 PDT
This incident affected: User Proofing (ID verification).