Dash Sends and Receives Delayed
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Nov 18, 2022 - 20:42 PST
Investigating
We are currently investigating this issue.
Posted Nov 18, 2022 - 18:59 PST
This incident affected: Digital Currencies (Dash).