Increased load times on Coinbase.com
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Aug 15, 2016 - 16:45 PDT
Identified
Our team is aware of the issue, and pushing out a fix
Posted Aug 15, 2016 - 15:16 PDT