Sign up issue

Incident Report for Coinbase

Resolved

Exchange sign up has been fixed.
Posted Sep 24, 2015 - 15:55 PDT

Identified

We have identified a sign up issue with the exchange and are working on a fix.
Posted Sep 24, 2015 - 15:52 PDT