Slow load times & degraded performance

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted May 25, 2017 - 14:02 PDT

Identified

We're continuing to experience slower than normal load times on Coinbase.com some customers might experience degraded performance. We appreciate your patience while we address this issue.
Posted May 25, 2017 - 06:49 PDT