XLM withdrawals delayed
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Oct 06, 2021 - 19:05 PDT
Investigating
We are currently investigating this issue.
Posted Oct 06, 2021 - 18:09 PDT