Delayed SEPA payouts
Incident Report for Coinbase
Resolved
All delayed Euro withdrawals have been sent, and will arrive within the next business day. Currently pending and new withdrawals are not expected to be delayed.
Posted 7 months ago. May 10, 2017 - 15:26 PDT
Identified
We're currently investigating issues with delayed SEPA payouts from May 2nd, May 4th, and May 9th withdrawals. Our team is actively working towards a fix, and we hope to have these expedited today.
Posted 7 months ago. May 10, 2017 - 09:13 PDT