Kava Delayed Sends
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Apr 14, 2024 - 11:44 PDT
Investigating
We are aware that some users may be experiencing delayed sends for Kava. We are investigating this issue and will provide an update shortly. Rest assured, your funds are safe.
Posted Apr 14, 2024 - 11:30 PDT