Degraded Stellar (XLM) Deposits and Withdrawals
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Oct 28, 2022 - 08:00 PDT
Investigating
We are currently investigating this issue.
Posted Oct 28, 2022 - 07:08 PDT