Issues with identity verification
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Nov 02, 2020 - 18:25 PST
Investigating
We're investigating issues with identity verifications for some customers. We'll update as we know more.
Posted Nov 02, 2020 - 16:24 PST
This incident affected: User Proofing (ID verification).