Delayed Sends/ Receives - Noble Network

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 13:23 PDT

Investigating

We are aware that some users may be experiencing delayed sends and receives on the Noble network. Buys, Sells, and Fiat withdrawals/deposits remain unaffected. We are working on this issue and will provide updates as the situation changes. Rest assured your funds are safe.
Posted Mar 25, 2025 - 11:50 PDT