Delays in EU & UK card withdrawals
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Apr 30, 2021 - 23:25 PDT
Identified
We're investigating delays when customers in the EU or UK withdraw funds from Coinbase to their debit cards. We will provide an update when we have more information.
Posted Apr 30, 2021 - 15:58 PDT
This incident affected: Payment Methods (Credit & Debit Cards).