Delayed Polkadot (DOT) withdrawals
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 21:59 PST
Investigating
We are currently investigating this issue.
Posted Nov 15, 2021 - 21:29 PST
This incident affected: Digital Currencies (Polkadot).