Delayed Deposits / Withdrawals on EOSIO (EOS)
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 15:18 PDT
Investigating
We are currently investigating this issue.
Posted Apr 28, 2022 - 11:59 PDT
This incident affected: Digital Currencies (EOS).