Help Center Support Form Outage
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Dec 22, 2021 - 09:03 PST
Investigating
We are experiencing a technical issue with our submission form and are currently unable to receive any submissions. We are working to resolve this as quickly as we can and will provide an update on the Help Center.
Posted Dec 22, 2021 - 04:47 PST
This incident affected: Customer Support.