International USDC Trading
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Aug 23, 2022 - 07:06 PDT
Identified
We plan to relist our USDC-EUR, USDC-GBP, and USDT-USDC order books in the coming weeks.
Posted Jul 27, 2022 - 08:13 PDT
Investigating
USDC trading is impacted for some international users on Advanced Trade as a result of the merger of USD and USDC order books. We are working on a solution to re-enable trading. Updates will be provided here.
Posted Jul 19, 2022 - 09:08 PDT
This incident affected: Digital Currencies (USD Coin).