Help Center Support Form Partial Outage
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Nov 05, 2021 - 08:51 PDT
Investigating
We are experiencing a technical issue with our submission form and are currently unable to receive some submissions. We are working to resolve this as quickly as we can and will provide an update on the Help Center.
Posted Nov 05, 2021 - 07:59 PDT
This incident affected: Customer Support.