Delays in identity verifications
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Jun 03, 2020 - 13:49 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 03, 2020 - 13:49 PDT
Update
Due to the impact of COVID-19 we are experiencing slower than normal response times processing identity verifications
Posted Mar 21, 2020 - 15:20 PDT
Identified
The issue has been identified
Posted Mar 21, 2020 - 14:00 PDT
Investigating
We are experiencing delays in processing identity verifications
Posted Mar 21, 2020 - 12:04 PDT
This incident affected: User Proofing (ID verification).