Delayed Polkadot (DOT) deposits and withdrawals
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Jun 08, 2022 - 07:48 PDT
Investigating
We are currently investigating this issue.
Posted Jun 08, 2022 - 07:09 PDT
This incident affected: Digital Currencies (Polkadot).