US Instant Bank Account Withdrawals are experiencing a delay
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Jun 23, 2022 - 17:07 PDT
Monitoring
A fix has been implemented, we are monitoring the results.
Posted Jun 23, 2022 - 17:07 PDT
Investigating
We are currently investigating the issue
Posted Jun 23, 2022 - 16:41 PDT
This incident affected: Payment Methods (US Bank Accounts).