Delayed Transactions (DOGE)

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted 1 year ago. Nov 28, 2023 - 12:21 PST

Investigating

Sends/receives are delayed for Dogecoin (DOGE). While we work on a fix, your funds remain secure.
Posted 1 year ago. Nov 27, 2023 - 22:30 PST
This incident affected: Digital Currencies (Dogecoin).