iDEAL Payments Service Disruption
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted May 15, 2021 - 18:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2021 - 18:03 PDT
Identified
We have identified an issue causing iDEAL payments to be temporarily unavailable. We will update you when we have more information.
Posted May 15, 2021 - 16:57 PDT
This incident affected: Payment Methods (iDEAL).