Help Center and support form outage

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted Feb 01, 2020 - 09:39 PST

Investigating

We're currently experiencing an outage with our Help Center and support forms. Our team is working to fix this, and we'll send an update when this issue is resolved.
Posted Feb 01, 2020 - 09:06 PST
This incident affected: Customer Support.