Delayed ALGO transactions
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 20:32 PDT
Investigating
Sends/receives for Algorand (ALGO) are delayed. While we work on a fix, your funds remain secure.
Posted Sep 15, 2023 - 14:54 PDT
This incident affected: Digital Currencies (Algorand).