ETC Send / Receive Delayed Due to Network Upgrade
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 08:10 PDT
Investigating
We are currently investigating this issue.
Posted Jun 01, 2020 - 07:35 PDT
This incident affected: Digital Currencies (Ethereum Classic).