Delayed Cardano (ADA) Withdrawals

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted Jun 14, 2022 - 20:48 PDT

Investigating

We are currently investigating this issue.
Posted Jun 14, 2022 - 13:12 PDT
This incident affected: Digital Currencies (Cardano).