Delayed Cardano (ADA) deposits and withdrawals
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Jun 29, 2021 - 17:15 PDT
Investigating
We are currently investigating the issue.
Posted Jun 29, 2021 - 15:26 PDT
This incident affected: Digital Currencies (Cardano).