Investigating unavailability of Help Center
Incident Report for Coinbase
Resolved
We've resolved the issue. All systems are operating normally.
Posted Oct 13, 2019 - 10:27 PDT
Investigating
We're investigating unavailability of our Help Center and Support forms at support.coinbase.com. We'll share updates as we have them. We apologize for the inconvenience.
Posted Oct 13, 2019 - 08:56 PDT
This incident affected: Customer Support.