Delayed withdrawals on AVAX (Avalanche)
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Nov 22, 2021 - 15:06 PST
Update
We are continuing to investigate this issue.
Posted Nov 22, 2021 - 11:58 PST
Investigating
We are currently investigating this issue.
Posted Nov 22, 2021 - 11:55 PST
This incident affected: Digital Currencies (Avalanche).