Help Center Support Form Response Delayed
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Aug 17, 2020 - 16:33 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2020 - 16:23 PDT
Investigating
We are experiencing a technical issue with our submission form, which may cause a slight delay in our response. We’ll reach out to you as soon as possible.
Posted Aug 17, 2020 - 15:47 PDT
This incident affected: Customer Support.