3DS payments degraded
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted May 26, 2020 - 09:30 PDT
Investigating
We are currently investigating this issue.
Posted May 26, 2020 - 08:20 PDT
This incident affected: Payment Methods (EU Debit / Credit Cards (3DS)).