Delayed XTZ Deposits and Withdrawals
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Dec 30, 2020 - 19:50 PST
Investigating
We are currently investigating this issue.
Posted Dec 30, 2020 - 17:54 PST
This incident affected: Digital Currencies (Tezos).