Coinbase Help Center is Down
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Apr 06, 2024 - 19:53 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 06, 2024 - 19:51 PDT
Investigating
We are aware that some users may be unable to access help.coinbase.com and live chat support. Users are still able to contact support at 1-888-908-7930 or through the Coinbase app. We are working to resolve this as quickly as possible, rest assured your funds are safe.
Posted Apr 06, 2024 - 18:59 PDT
This incident affected: Customer Support.