Polkadot (DOT) - Delayed Sends & Receives

Incident Report for Coinbase

Resolved

This incident has been resolved.
Posted Mar 16, 2024 - 13:54 PDT

Identified

We are aware that some users may be experiencing delayed sends and receives for DOT. We are investigating this issue and will provide an update shortly. Rest assured, your funds are safe.
Posted Mar 16, 2024 - 11:52 PDT
This incident affected: Digital Currencies (Polkadot).