ATOM - Delayed Sends & Receives
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Jan 20, 2025 - 09:45 PST
Investigating
We are aware that some users may be experiencing delayed sends and receives for Cosmos (ATOM). We are investigating this issue and will provide an update shortly.
Posted Jan 20, 2025 - 08:54 PST
This incident affected: Digital Currencies (Cosmos).