Degraded performance - SGD Deposit

Incident Report for Coinbase

Resolved

This issue has been resolved. SGD deposits via FAST/PayNow are now processing normally. Thank you for your patience.
Posted May 18, 2026 - 02:34 PDT

Investigating

We are aware that some users may be experiencing degraded performance when depositing funds via FAST / PayNow. Our team is investigating this issue and will provide an update shortly. Your funds are safe.
Posted May 18, 2026 - 00:03 PDT
This incident affected: Payment Methods (FAST (Singapore)).