Delayed Payments - Australia
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted Mar 07, 2023 - 03:59 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2023 - 03:11 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 07, 2023 - 03:10 PST
Investigating
Our team is aware of a delay with payment transactions in Australia. Please do not resend payments while we work to fix the issue.
Posted Mar 07, 2023 - 03:01 PST
This incident affected: Payment Methods (PayID (Australia)).