BTC Delays
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted 8 days ago. Dec 08, 2017 - 15:38 PST
Investigating
We are experiencing a significant backlog in outgoing BTC transactions. Our team is investigating the issue. Customers may experience a delay when sending BTC from Coinbase.
Posted 10 days ago. Dec 06, 2017 - 12:17 PST