Issues with ID verification
Incident Report for Coinbase
Resolved
This incident has been resolved.
Posted May 02, 2021 - 19:01 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 01, 2021 - 13:55 PDT
Investigating
We're investigating issues with ID verifications for some customers. We'll update as we know more.
Posted May 01, 2021 - 03:08 PDT
This incident affected: User Proofing (ID verification).