ID Verification Outage
Incident Report for Coinbase
Resolved
ID verification services have been restored and are operating normally.
Posted 17 days ago. Nov 29, 2017 - 12:18 PST
Investigating
ID verification is currently unavailable due to a service outage with our verification provider.
Posted 17 days ago. Nov 29, 2017 - 08:16 PST